Forums
in > Search
Welcome to Pinnacle Systems - Forums Sign in | Join | Help

Import module missing directories in Studio 19 Ultimate

Last post 03-29-2016, 21:23 by culpanr. 13 replies.
Sort Posts: Previous Next
  •  03-18-2016, 20:19 708335

    Import module missing directories in Studio 19 Ultimate

    Attachment: StudioCap2.PNG

    When I use the Importer and select My Computer I can browse the local drives. I have a mapped drive f: that connects to a network share on the NAS.

    Windows explorer, Picassa and other programs can routinely use it. However when I open the Importer and click the + by the drive it does not expand or see any of the sub directories. The scan media also has this issue. I have checked and there are only 23 directories on that drive and maybe 100 files in them. If I open a Windows File window and drag the files into the Library they show in the latest import. I want to use the Importer to set the metadata and use other features during import.

    I am on Windows 10 64x

    The Backups drive also has the same issue. Although the Pictures (no video files) drive does not seem to have the same problem. I did check and the file permissions for all three mapped drives are the same.

    Any idea how to get the importer to see the sub directories.

    Thanks

     


  •  03-18-2016, 21:12 708351 in reply to 708335

    Re:Import module missing directories in Studio 19 Ultimate

    I'm almost sure Studio can't handle correctly networked drives. ISTR old discussions about it.
  •  03-18-2016, 22:32 708367 in reply to 708351

    Re: Re:Import module missing directories in Studio 19 Ultimate

    That is unfortunate. Are you talking about the \\computer\path kind of drive or the using Windows to map an external drive to a drive letter. Also I am unfamiliar with the ISTR term.
  •  03-18-2016, 23:29 708370 in reply to 708367

    Re: Re:Import module missing directories in Studio 19 Ultimate

    I talk about drives that are not physicaly attched to the computer.

    ISTR = I Seem To Remember.

    Smile 

  •  03-18-2016, 23:38 708371 in reply to 708367

    Re: Re:Import module missing directories in Studio 19 Ultimate

    Studio has certainly had trouble with UNC-named shares (\\computer\share). But I vaguely remember legacy versions (going way back - probably in the days of Studio 9 or 10) also having trouble with external hard drives if their assigned letters were "too high" (coming after any optical drives)...

    Couple of ideas to try:

    • Map your shared drives using their host names instead of their IP addresses; use a name server or local HOSTS/LMHOSTS files to resolve the names if the PC can't pick them up off the network (via the names broadcast by the NAS drives)...
    • Try changing the drive letter of your CD/DVD drive (move it "up") and try mapping your network drives onto lower drive letters (for example make your CD/DVD drive "H" and try mapping one of the network drives as "G" and see if the Importer then picks up the files/folders from it - if it does not, just put the drive letters back as they were...)

    HTH (= hope this helps)
    Richard

  •  03-19-2016, 5:12 708375 in reply to 708371

    Re: Re:Import module missing directories in Studio 19 Ultimate

    I did not even think of that part about the drive letters. I will create a test case and see. Although one of the mapped drives (Y:) does seem to work as I would expect and it is after the optical drive. But this is a drive with only photos no video files.

    Thanks

     

    saby:

    ISTR = I Seem To Remember.

    I am so so old school and maybe should stick with the emoticons

    Embarrassed 

  •  03-20-2016, 6:44 708433 in reply to 708371

    Re: Re:Import module missing directories in Studio 19 Ultimate

    I tried moving my DVD drive to H and created a new mapped drive F. Restarted and fired up Studio's import area. It did see the new drive but the + did not expand and find the contents. I also have tried running Studio as an administrator.

    I can still drag and drop into the library and use the latest import to move things around.  However I would like to skip the extra steps for updating the metadata. I work from the home NAS since it is a Synology with 12TB of RAID 5 and a 1GB network. The local C drive where Studio is installed is a flash drive and I have a second flash drive set for the temp / render files. The network gives 120MB /s which is faster then the non-flash drives I could use.

    Any other ideas?

    Thanks

  •  03-20-2016, 12:53 708454 in reply to 708433

    Re: Re:Import module missing directories in Studio 19 Ultimate

    Thanks for the feedback...

    Out of curiosity, I did a test here (I also have a Synology NAS - DS213+ with DSM 5.2-5644 Update 5). PC used was an Intel NUC 6i5SYH ultra-small form factor, Windows 10 Home (1511) 64 bit (clean-install from OEM DVD and patches up-to-date), Studio 19.1.3 Ultimate 64 bit.

    Mapped drive from NAS as drive letter Z:, opened Studio's Importer and I am able to expand the folders on the mapped drive, and if I enter a folder where there are assets such as video files that could be imported, Studio's Importer does retrieve the thumbnails and I can click the check-boxes to select which ones I want to import (didn't go as far as actually doing an import...)

    FYI, in case my NAS settings are different from yours (and that difference is significant) - two changes I made from the Synology defaults:

    • I have created a user account on the NAS having the same credentials as the local user account I use to log in to Windows ("pass-through authentication"). File/folder access on the NAS is governed by the user accounts, not simply being open to "everybody".
    • I have enabled use of SMB3 in the NAS (control panel | network settings) - not enabled by default (and may be needed by Windows 10 unless you have applied the widely-publicised hack to turn off SMB2/3 and use only SMB1).

    Regards,
    Richard

  •  03-20-2016, 22:40 708497 in reply to 708454

    Re: Re:Import module missing directories in Studio 19 Ultimate

    I have DSM 5.2-5644 Update 5 on a DS 1515+. I turned on SMB3 (it was also off). I have the same setup as you on the local users to windows pass through. I had 19.1.2 so I applied 19.1.3. I then removed all watch folders from Studio and mapped drives from windows. I restarted and opened Studio to see if it had forgot about them. After that I created a new Windows drive mapping and started Studio. It saw the drive in the import but the + did not expand.

     I am not sure what else to do. Since yours mapping did work it obviously is something in my setup. I have 4 mapped drives on my setup. How many do you have? Maybe studio only can work with the first one it finds. I will test that out later tonight.

     Thanks

  •  03-21-2016, 10:18 708524 in reply to 708497

    Re: Re:Import module missing directories in Studio 19 Ultimate

    I only had one mapped drive at the time (normally I don't have any as I don't use video files etc. from the Synology NAS - it it used for keeping backups and only switched on when needed).

    But in response to your comment I have tried again today with two drives mapped - added a D-Link DNS-320L (on which I had backed up a bunch of camera memory cards) and can browse both that and the Synology DS213+ (screen shot attached - the DNS-320L is drive Y: and the DS213+ is drive Z:).

    So, assuming that your installation of Studio has no trouble browsing and importing from local hard drives (fixed or removable), I would suspect an issue with Windows networking. I have listed some points where your configuration might be different to mine (although those differences could be completely harmless):

    • Is your installation of Windows 10 a clean install (whether installed by the PC manufacturer or by you), or is it an upgrade from a prior version of Windows (e.g. the free upgrade from qualifying Windows 7/8 versions)? (Here, the PC I use most of the time is a clean-install, however the other two are the free upgrades (one from Windows 7 Home Premium, one from Windows 8.1 Pro)).

    • If it was an upgrade from Windows 7/8 (keeping existing user files/apps/settings), do you remember if you had to do any networking hacks in the old version of Windows to make it work with the NAS? (A long shot, but maybe a hack applied to Windows 7 has been carried forward into Windows 10, and is no longer needed and incompatible...)?

    • Do you have more than one PC on your local network? If so, are they all Windows 10? (I have three PCs here, although the other two are seldom "on").

    • If you have multiple PCs, do any of them have trouble accessing the NAS, for example not seeing it in the "Network" branch in Windows Explorer/File Explorer, or taking a long time to map a drive or retrieve the list of files/folders from it?

    • Do you have the NAS set as "master browser"? (Here, I do not - using Synology's default setting of "no" (tick-box not checked. So whichever PC I turn on first will be master browser)

    • Do you use IPv6 (or have it enabled in the network adapter settiongs)? (Here, most of my other network devices don't support it, so I have turned it off in both Windows (network adapter properties) and in the Synology NAS (network properties. So everything here uses IPv4 only).

    FWIW I did have trouble with Windows networking a while back - but eventually found that was down to the configuration of one PC (an Acer nettop - upgraded from Windows 7 Home Premium 64 bit to Windows 10 Home); when that one was switched on first (so was master browser), no other PCs could see any network shares (or even see each other)! "Sniffing" the network by running the Wireshark packet capture tool showed that PC was misbehaving and ignoring requests for the list of network devices from the other PCs. Problem was solved by a clean-reinstall of Windows 10 - so that PC had clearly carried forward some unpleasant setting from Windows 7 when I upgraded it...

    Regards,
    Richard


  •  03-24-2016, 16:06 708791 in reply to 708524

    Re: Re:Import module missing directories in Studio 19 Ultimate

    I did some more experimenting. I unplugged all computers from the network except the workstation, NAS and router (DHCP, DNS Static hosts etc..). I restarted all of the above. I did check the master browser setting and it was also "No". I still have the same behavior occur. I use IPv4 not 6 and have it disabled on the computers, router, and NAS. I also added exceptions in Windows Defender for the studio / BG renderer processes as well as the mapped drives. So since it seems to work on the camera photos (Canon SL1 RAW files) but not the MTS HD files in the other two directories I am looking in that direction. I created a new test network mapping to the photo drive as T: and it also worked in studio.

    I did open a support ticket and they said to update my video card drivers and turn up the screen resolution. Both of the suggestions did not change it.

    One thing I did notice is that I have Direct X 12 installed. I do not remember doing that but Windows 10 seems to do more on it's own.I may look into removing that and installing the one that came with the Studio install.

    Thanks again for your help

  •  03-24-2016, 19:34 708808 in reply to 708791

    Re: Re:Import module missing directories in Studio 19 Ultimate

    OK on your further tests:

    Wasn't sure from your posting whether your test mapped drive T: worked for both photos and videos, or only for photos. As network access is working for photos, that suggests that the basics of Windows networking is OK, and the problem could be something to do with how the video files are stored (any strange file/folder permissions?), or a problem in Studio...

    DirectX 12 is a standard part of Windows 10 - you won't get rid of that in a hurry. But Studio probably isn't using it (for backwards compatibility with Windows 7/8/8.1 it would need to be using something older (9/10/11). But a DirectX error would IMO be more likely to cause instability, problems with drawing user interface elements, problems previewing etc. Display driver issues would IMO be more likely to cause instability, UI drawing, preview and export problems, not a networking issue...

    Studio iteslf and the Studio background processes shouldn't need any special handlng in the Windows firewall over & above anything done by Studio's installer; network access is needed to the local machine only (a throwback to the days of Avid Liquid, that did support editing and exporting in a networked environment, with multiple workstations).


    My "gut feeling" is that there could be something strange about the NAS folders in which the video files are stored - especially if you can't even see those folders by clicking the '+' beside the drvie's entry in the tree.

    • Were those folders created manually by you, or were  created by some app you were using to copy the files from the camera onto the PC?
    • If you manually create a new, empty folder on the NAS, can Studio's Importer see it?
    • If Studio's Importer can see a manually-created folder, what happens if you use Windows Explorter/File Explorer to copy various "importable" assets (photos, video files, audio files etc.) into that folder? When you go into the Importer and browse that folder, can Studio now see what is inside?

    If Studio's Importer seems to work OK with the manually-created folder, carefully check the ownershiip and security settings for the files/folders that the Importer cannot see, in the hope that you can spot any significant differences...

    HTH
    Richard

  •  03-29-2016, 19:00 709092 in reply to 708808

    Re: Re:Import module missing directories in Studio 19 Ultimate

    OK so I had success. I updated the NAS to the new DSM v6. I did the manual uninstall and used revo to clean up the leftovers of studio. After I reinstalled and applied the latest patch I created a new file share on the NAS. Then mapped it to windows and opened studio. It saw the empty drive. I then closed studio and created 2 directories on the share. Back to studio and the plus opened and saw them. I then copied the contents of the old share to the new one and studio saw the files and made thumbnails. I repeated for the other 2 mapped drives and now I am back in business.

    I am not sure what the fix was.

    Updated DSM software, new NAS shares and mapped drives, or reinstalled studio. Either way I can now use the importer functionality.

     

    Thanks so much for your help. It is very much appreciated.

     

    -- Cheers

  •  03-29-2016, 21:23 709098 in reply to 709092

    Re: Re:Import module missing directories in Studio 19 Ultimate

    Thanks for posting back - glad it's working now (however it was fixed) Big Smile

    And thanks for "heads up" on DSM v6; I'll see if it's available for the DS213+ and if it brings anything I want.

    Regards,
    Richard

View as RSS news feed in XML
Copyright © 2012 Corel, Inc.. Terms of Use | Privacy Policy