Forums
in > Search
Welcome to Pinnacle Systems - Forums Sign in | Join | Help

Studio " hidden patches" and Hot fixes S12, 14 and 15

Last post 03-10-2012, 4:31 by jjn. 12 replies.
Sort Posts: Previous Next
  •  05-30-2010, 1:42 402072

    Studio " hidden patches" and Hot fixes S12, 14 and 15

    People going straight to the downloads support page for Studio 14 & 15 won't find any patches. To my knowledge there is at least two official ones and one beta one, but they are "hotfixes" which you aren't encouraged to apply unless you have the problem. This is probably because they haven't been as extensively tested as a full patch and could cause issues elsewhere.

    http://avid.custkb.com/avid/app/selfservice/search.jsp?DocId=420535&NewLang=en&DocType=1079

    Studio 15 DVD recorder Import Hotfix

    Full instructions and the download link HERE

    Fixes an issue where discs from certain DVD recorders imports only a small portion of the video

    Studio 14 YouTube Upload patch

    Full instructions and link to the download HERE

    It fixes YouTube upload problems caused when YouTube changed it's upload routines.

    In addition, there is a beta patch PAL DV camera users

    Studio 14 DV PAL Beta patch

    Full instructions and link to the download HERE

    another one is now HERE

    It may fix firewire import issues for people with PAL cameras.

    Studio 12 has a "hidden" patch that isn't listed on the download page, too.

    Studio 12.1 DVD Import patch

    Full instructions and link to the download HERE in the second section regarding file replacement.

    Workaround patches

    Not posted by Avid, there are a couple of posted workarounds that require downloads

    Studio 12.1 alternative DVD Import patch

    The DVD Import dll from Studio 11 may give better results in some circumstances that the official patch.

    Replacing the DLL as instructed in THE KB ARTICLE, File replacement section, but with the dll file from Studio 11, version 2.0.19, cures problem for some people in some circumstances. If you don't have Studio 11, the DVDReader.dll file 2.0.19 is available for download HERE

    Also, the YouTube patch for S14 seems to work for S12

    Studio 12.1 unofficial Youtube Upload patch

    If you replace the S12 PinnacleWebPublisher.exe file in S12 (version 1.0.68) with the latest file that Pinnacle are posting as a patch to S14 (1.0.78) it may solve your YouTube upload problems. Please don't do this without backing up the old file first.

    For those of you who don't have S14 and therefore can't extract the PinnacleWebpublisher.exe file, it has been posted HERE.

    This fix was discovered by VIO

    S14 DVD creation bug workround...

    S14 Older DVD player compatibility. Studio 14 has made backward steps when it comes to making DVDs that play correctly on older DVD players. This problem can be solved in two ways. The safest way is to download a copy of IMGBurn from www.imgburn.com and use that to burn the discs. Use Studio “Create disc content but don’t burn” setting to make a Video TS folder, and then follow the guide at forum.imgburn.com/index.php?showtopic=4632 to burn your DVD, or download THIS PDF

    The second way to work round this also solves another problem….

    S14 RTM markers always return to Menu 1. You will encounter this issue if you make a DVD that has more than one menu. A Return to Menu 2 (or above) won’t return you to where you would expect, but to Menu 1.

    This problem (and the compatibility issue above) seems to be solved by replacing some elements of S14 with parts of S12. I have done this and have not suffered any side effects at the moment, but please remember you do so at your own risk. I haven’t tested what it might do to creating discs other than SD DVD single layer.

    To do this you need a copy of the Studio 12 PCLE.DiscAPI folder and its contents. I have hosted a copy here - www.dtvpro.co.uk/PCLE.DiscAPI.zip but if Pinnacle object to this being available I will remove it.

    In Win7 and XP (and I assume Vista) the path to find the folder is C:Program files/Pinnacle/Studio 14/Programs. Rename the folder to PCLE.DiscAPIold and then extract the copy the S12 version from the zip file and put it into the same location.

    This solution was discovered by Ronny01 using the S11 DiscAPI. It has now been tested it with S12's API)



    AVCHD incorrect thumbnailfix

    AVCHD Thumbnails are incorrect in the Importer

    The fix for this is described by VIO HERE

    Anyone else?

    (Please note I'm not claiming any credit for these workrounds. If anyone else feels they need credit for discovering them please PM me. It is the intention of this thread to make stuff easier to find by putting them in one place)

  •  05-30-2010, 4:06 402084 in reply to 402072

    Re: "Hidden" Studio patches

    How did you find them?

     

    I'm looking for  a patch that fixes this product... wondering, if they are doing anything at all to keep customers satisfied?

     

    K

  •  05-30-2010, 9:31 402108 in reply to 402084

    Re: "Hidden" Studio patches

    How did you find them?
    By spending too much time reading the forum Wink

    What do you want fixed? If you are using Canon footage7D with your current computer, you are seriously underpowered.

  •  05-31-2010, 12:34 402262 in reply to 402108

    Re: "Hidden" Studio patches

    jjn:
    If you are using Canon footage7D with your current computer, you are seriously underpowered.

     

    Yes, you are so right about that fact. It is my next target, more power...

    Well, there's so many little annoyances with PS14.
    First thing in my mind is that when I put videos to the timeline, and I try to watch it, video comes after sound, badly out of sync.
    Some effects just doesn't work correctly. And some effects are missing (so they are not broken), something that should be included. like motion tracking.
    Speed effect is not working correctly after applying, it part of the video is missing, and it only gives 5x max speed (why not limitless?).

    I had two video clips combined. To make it editable, I saved the project and create MPG format, open it again, and tried to cut it exactly between the point where it changes. For some reason, if I do exctly where it should be, it leaves many frames to a wrong side of the cutting point. Moving the point for just one frame, it cuts it, but moves one frame ahead and flashes it after one second... very strange, error in programming.

    Those little things should be corrected quickly, if there's patches available...? I'm sure that I am not alone with these problems.

    K

     
  •  06-10-2010, 9:54 404207 in reply to 402262

    Re: "Hidden" Studio patches

    Pinned
  •  06-14-2010, 5:44 404869 in reply to 404207

    Re: "Hidden" Studio patches

    Hi
  •  06-14-2010, 5:46 404871 in reply to 404207

    Re: "Hidden" Studio patches

    Hi

     Are there any pacthes for Studio 14 menu issues i.e. RTM after each chapter causing menus to freeze or not work?

  •  06-14-2010, 6:07 404874 in reply to 404871

    Re: "Hidden" Studio patches

    According the Pinnacle, the only fault they currently recognise with RTMs in S14 is that they always return you to Menu 1 - where ever they are pointed to.  See THIS. That makes it look as if they aren't intending to fix the issue.

    I've not seen any mention of a fix for other DVD issues. Using IMGBurn solves it for me on my old DVD player - and I almost always use IMGBurn anyway as I can use bitsetting.

    In another thread is it you that is doing all the testing? Keep up the good work Smile

  •  09-16-2010, 2:41 421733 in reply to 404874

    Re: "Hidden" Studio patches

    Was this thread ever pinned, or has it been unpinned?
  •  12-12-2010, 1:36 438959 in reply to 402072

    Re: "Hidden" Studio patches

    Thanks for that

    I have been very frustrated trying to upload to YouTube I thought it was an issue with my hardware/internet connection. After the install of the patch for Studio 14 on wards  up wards 

     

    Thanks  again for the discovery.

  •  12-15-2010, 3:43 439724 in reply to 438959

    Re: "Hidden" Studio patches

    countstefan:

    Thanks for that

    I have been very frustrated trying to upload to YouTube I thought it was an issue with my hardware/internet connection. After the install of the patch for Studio 14 on wards  up wards 

     

    Thanks  again for the discovery.

     

    I've never tried to youtube upload  from Studio -- what advantage is there in doing that ??  is it faster, better ???

    Youtube from the browser now gives 2gb HD, and 15 minutes (if not more) -- and its pretty quick 

  •  01-23-2011, 6:09 448907 in reply to 439724

    Re: "Hidden" Studio patches

    I've never tried to youtube upload  from Studio -- what advantage is there in doing that ??  is it faster, better ???
    The only advantage I can see is simplicity. The disadvantage is that it leaves the render files in places you won't look and doesn't automatically delete. Perhaps the next version of Studio will have HD uploading as well?
  •  03-10-2012, 4:31 520780 in reply to 448907

    "Hidden" Studio patches and hotfix topics Studio 12, 14 and 15

    Hidden Studio 12 and 14 patches

    I've now pinned this thread. I've also added this post so that it turns up in searches.

    There is another hotfix for S15 now added to the first post

View as RSS news feed in XML
Copyright © 2012 Corel, Inc.. Terms of Use | Privacy Policy