Welcome to Pinnacle Systems - Forums Sign in | Join | Help

Re: Poor MP4 quality

  •  10-17-2019, 18:48

    Re: Poor MP4 quality

    culpanr:

    I'm surprised that you haven't been able to get a decent MP4 export from Studio... I also used to archive completed video and captures from old miniDV tapes as MPEG-2 but switched to MP4 (with H.264 video encoding) as the files were smaller and the export quicker (also able to use hardware acceleration).

    I wonder if there is an issue with export settings? I would suggest the following:

    • Project (timeline) settings - match the format of the source clip that you're archiving, so if it's standard definition NTSC 16x9, and is interlaced, choose the preset "NTSC Widescreen" and make sure that the frame rate is "29.97 (60i) for NTSC" and not "29.97 (30p) for NTSC"

    • In the Exporter, choose the format as "H.264/AVC" - NOT "MPEG-4 Visual" as that is an old legacy codec and nowhere near as good as H.264

    • The "Same as Timeline" check-box may result in settings that aren't what you want (for example, if the only things on the timeline are DV AVI files it may set the format as DV). Instead, choose Custom settings:

      • Choose a Custom frame size and enter the size as 720x480 - matching your source file - this is important as standard-definition DV uses rectangular (not square) pixels
      • Choose interlacing as "Top Field First" (this appears to be the "industry standard" for all kinds of MPEG files)
      • Verify that the frame rate is still shown as 29.97 (adjust if necessary)
      • Enter the desired video bit rate (the entry will accept decimal values of bit rate in Mbit/sec, but will only display the rounded "whole number" part). I would suggest a starting value of 3 Mbit/sec
      • Set a sensible value for the audio bit rate - the "out-of-box default" of 112kbit/sec is IMO a little too low; for a soundtrack that is mostly speech I would suggest no lower than 128kbit/sec, but if there's a lot of good-quality music (added from audio files, Scorefitter or Smartsound) I would suggest 192kbit/sec or 256kbit/sec (IMO no point going any higher - audio quality won't improve much and the file will take up more space)

    Note that there may be issues with the export if hardware acceleration is in ise (CUDA or Intel):

    • In some cases, export using CUDA (Nvidia) hardware accleration may result in a file that is unplayable in Windows Media Player (or WMP is extremely slow to jump to different parts of the video using its seek bar)
    • In some cases, export using Intel hardware accelerarion may exhibit flicker (some random still-frames get interspersed with the expoirted video)

    If either of the above problems are experienced, turn off hardware acceleraton in Studio's control panel (choose the setting as "None" and repeat the export - this appears to be "slow and reliable".

    HTH
    Richard

    I'll try again. (What have I got to lose?) I'm also surprised that I've had so much trouble. MediaInfo tells me that the original file is bottom-field-first, so I will use that and reverse if the results are poor, just to see. And I did force the output to 720 x 480 once and wound up with a 3:2 aspect ratio. Will try again, though. Thanks.

View Complete Thread
Copyright © 2012 Corel, Inc.. Terms of Use | Privacy Policy