Welcome to Pinnacle Systems - Forums Sign in | Join | Help

SC200 / 250 Power supply / Remote Issues

  •  07-19-2009, 8:00

    SC200 / 250 Power supply / Remote Issues

     Hi,

     If ,like me, you've had any problems with a showcenter which will not respond to the remote control, even though it appears to be otherwise OK, it could be that there has been a failure of its' power supply. First you need to confirm if possible that the remote itself is OK - change the batteries etc, try a different one if you have one, try it with a different showcenter - whatever you can.

     If the remote is OK, but the green light on the showcenter does not flash when you press a button, then it is likely that one or more of the capacitors on the power supply has failed. The short guide below shows how you can replace the capacitiors and get it up and running again.

    http://www.sewwhat.gb.com/paul/Showcenter_not_responding_to_remote.pdf

    If your showcenter is completely dead, it may also be worth taking off the lid and checking the power supply - especially if it is no longer in warranty - to see if there are any blown capacitors.

    If you are not competant with a soldering iron, I recommend that you ask someone who is to do this, as if you get things wrong you could potentially destroy the showcenter altogether.

    It's just a shame that Pinnacle insist on effectively crippling such a good little device by using poor quality components in the first place.

     

View Complete Thread
Copyright © 2012 Corel, Inc.. Terms of Use | Privacy Policy