Forums
in > Search
Welcome to Pinnacle Systems - Forums Sign in | Join | Help

3D- Video erstellen, 3 Fragen

Last post 04-28-2015, 18:56 by IngolfZ. 87 replies.
Page 3 of 4 (88 items)   < Previous 1 2 3 4 Next >
Sort Posts: Previous Next
  •  03-29-2015, 17:04 670595 in reply to 670549

    AW: 3D- Video erstellen, 3 Fragen

    Helmut1962:
    kann eigentlich St18 mit  mpo und jps Dateien umgehen und welches Format ist besser?

    Mit JPS habe ich keine Erfahrung. Mit MPO kann Studio gut umgehen. Es ist halt nur eine nichtdestruktive Bearbeitung möglich, so dass die Bildbearbeitung nur für Studio möglich ist (wurde an anderer Stelle schon kontrovers diskutiert). Welches der beiden Formate besser ist, kann ich natürlich nicht sagen, da ich mit JPS keine Erfahrung habe. Ein Vergleich ist im unten stehenden Link nachlesbar.

    http://www.anaglyphe.de/die-3d-dateiformate-mpo-und-jps/958

    Gruß, Herbert

  •  03-29-2015, 21:59 670619 in reply to 670595

    AW: 3D- Video erstellen, 3 Fragen

    Hallo Herbert,

    danke für den Link, habe es gerade getestet, beide Dateitypen erkennt St18, bei jps war es mir klar, sind ja auch die Schnappschüsse in diesem Format. Seltsamerweise, bleibt aber St18 mit den extern erstellten jps auch bei 50% hängen, wogegen aber bei jps Schnappschüssen und mpo-Dateien der Export fehlerfrei abgeschlossen wird. Werde mich daher bis zum Bugfix mit mpo-Dateien behelfen.

  •  03-30-2015, 7:52 670640 in reply to 670619

    AW: 3D- Video erstellen, 3 Fragen

    Helmut1962:
    Seltsamerweise, bleibt aber St18 mit den extern erstellten jps auch bei 50% hängen, wogegen aber bei jps Schnappschüssen und mpo-Dateien der Export fehlerfrei abgeschlossen wird. Werde mich daher bis zum Bugfix mit mpo-Dateien behelfen.

    Wie erstellst du denn jps-Dateien (Fotos) extern? Meine 3D-Fotoapparate erstellen beide in MPO.

    Ich dachte bis heute, dass die Schnappschüsse MPO-Dateien seien. Sie sind aber JPS. Von daher ist meine obige Aussage, dass ich keine Erfahrung mit JPS-Dateien habe, natürlich nicht richtig.

    Gruß, Herbert

  •  03-30-2015, 21:32 670712 in reply to 670453

    AW: 3D- Video erstellen, 3 Fragen

    IngolfZ:
    Er bleibt nicht bei 50% der Spieldauer des Videos stehen, sondern nach 50% des Fortschritts.

    Und das ist genau der Punkt, an dem das Rendern und die Zusammenstellung des Images fertig gestellt ist und mit dem Brennvorgang begonnen wird bzw. begonnen werden sollte.

    Auch bei einem ganz normalen Export in eine Datei "verhungert" der Export nach MultiStream, wenn sich ein 2D-Bild zusammen mit einem 3D-Clip in der Zeitleiste befindet. Das heißt, weder Imageerstellung noch einzuleitender Brennvorgang ist Schuld, sondern einzig die Kombination 2D-Foto und 3D-Clip. Aber nur bei einem Export nach MultiStream!

    Das sollte den Entwicklern kund getan werden. Diesen Fehler zu finden müsste doch einfach sein, wenn man weiss wonach zu suchen ist.

    Gruß, Herbert

  •  03-31-2015, 0:46 670716 in reply to 670712

    AW: 3D- Video erstellen, 3 Fragen

    Danny 28:
    .........Diesen Fehler zu finden müsste doch einfach sein, wenn man weiss wonach zu suchen ist.

    Gruß, Herbert

    Das setzt voraus, dass man auch suchen (und beheben) WILL ..... Devil

    Die Beiträge der Upper Level Verantwortlichen sind ja wie erwartet völlig verstummt. Was war das für eine Euphorie hier im Forum, als ein "hohes Tier der neuen Eigentümer" die Solidarität mit und die Wichtigkeit von uns KÄUFERN (Kunden, Geldgebern, SEIN Gehalt (mit)finanzierenden) "beteuerte". BULLSHIT!!! Sorry. Augenwischerei! Verarsche! NIX kommt mehr. DER hat ja sein 6-stelliges Gehalt sichergestellt. Was kümmert's die Eiche, wenn sich die Wilds.....

    OK, PiS hat einige "Vorteile" anderen NLE gegenüber, je nach dem was man machen möchte. Aber "kümmern" ist doch wohl was anderes, oder???? Und andere NLE haben natürlich Vorteile gegenüber PiS. Stichwort: Eierlegende Wollmilchsau. Die wird es nicht geben. Aber die Ignoranz von Corel wird sich irgendwann "rächen", leider zu Lasten der user die dem Produkt (immer noch) die Treue halten. Ich habe für mich die Vorteile/Anwendungen von PiS18U gefunden, für alles Andere was ich so zu schnippeln habe sind genug andere Alternativen installiert.

    So, das war jetzt genug OT von mir zum Thema 3D-3F Zip it!

  •  03-31-2015, 6:26 670725 in reply to 670716

    AW: 3D- Video erstellen, 3 Fragen

    KUB59:
    Danny 28:
    .........Diesen Fehler zu finden müsste doch einfach sein, wenn man weiss wonach zu suchen ist.

    Gruß, Herbert

    Das setzt voraus, dass man auch suchen (und beheben) WILL ..... Devil

    Die Beiträge der Upper Level Verantwortlichen sind ja wie erwartet völlig verstummt. Was war das für eine Euphorie hier im Forum, als ein "hohes Tier der neuen Eigentümer" die Solidarität mit und die Wichtigkeit von uns KÄUFERN (Kunden, Geldgebern, SEIN Gehalt (mit)finanzierenden) "beteuerte". BULLSHIT!!! Sorry. Augenwischerei! Verarsche! NIX kommt mehr. DER hat ja sein 6-stelliges Gehalt sichergestellt. Was kümmert's die Eiche, wenn sich die Wilds.....

    Hallo Uwe,  Psssst .....

    sonst geht's Dir auch noch so wie mir seinerzeit, als ich mich ( zurecht ) über die gleichen Mißstände aufgeregt hatte .... Big SmileDevil

  •  03-31-2015, 7:07 670732 in reply to 670725

    AW: 3D- Video erstellen, 3 Fragen

    Helmut42, ich widerspreche Dir nicht. Pinnacle Studio 18 stimmt in und an der Oberfläche. Unter der Haube gibt es aber jede Menge Reparaturbedarf. Habe derzeit das Gefühl, die Mechaniker sind im Zwangsurlaub, weil die Reparaturaufträge von oben ausgegangen sind.

    Sorry, ein vielleicht hinkendes Bild; aber nur vielleicht... 

  •  03-31-2015, 9:33 670765 in reply to 670712

    AW: 3D- Video erstellen, 3 Fragen

    Attachment: Test_3D.JPG

    Danny 28:
    Auch bei einem ganz normalen Export in eine Datei "verhungert" der Export nach MultiStream, wenn sich ein 2D-Bild zusammen mit einem 3D-Clip in der Zeitleiste befindet. Das heißt, weder Imageerstellung noch einzuleitender Brennvorgang ist Schuld, sondern einzig die Kombination 2D-Foto und 3D-Clip. Aber nur bei einem Export nach MultiStream!

    Das sollte den Entwicklern kund getan werden. Diesen Fehler zu finden müsste doch einfach sein, wenn man weiss wonach zu suchen ist.

    Da dachte ich mir: Reproduziere den Fehler mal schnell um es den Entwicklern kund zu tun, Pustekuchen. Offenbar war ich da zu naiv.

    Mangels Masse an 3D-Clips habe ich Herberts Clip vom PUT 2014 hergenommen, zusätzlich ein 2D Photo.

    TL(1920x1080, 25(50i), 3D)-Aufbau für den Multistream-Export:

    1. Importieren_011.MTS
    2. 2D Photo
    3. Importieren_011.MTS

    Der Export in eine Datei klappte ohne Probleme, nur am Ende des Photos ist Studio etwas langsamer geworden, hat aber danach die Geschwindigkeit wieder gesteigert.
    Dann habe ich die exportierte Datei zusätzlich auf die TL gelegt um zu sehen, ob es auch 3D ist. Dieser Zustand ist im beigefügten Screenshot zu sehen.

    Das einzige was ich gesehen habe, sind die extremen Pixelfehler auf dem rechten Auge, die sind sogar in den ersten Frames im Photo-Clip vorhanden.

    Herbert, bitte beschreibe mir mal genau ein Prozedere mit allen notwendigen Daten, damit ich den Fehler reproduzieren kann. Falls nötig bitte auch ein paar 3D-Clips zum DL zur Verfügung stellen.


  •  03-31-2015, 10:48 670778 in reply to 670765

    AW: 3D- Video erstellen, 3 Fragen

    Das Problem liegt offenbar doch wieder mal tiefer als zunächst angenommen. Mir ist es jetzt auch gelungen, einen Dateiexport durchzubringen. Andere haben nicht geklappt, da ist der Export einfach stehen geblieben.

    Aber auch bei der Imageerstellung ist bei mir die Sache nicht so klar. Ist das 2D-Foto am Schluss, geht alles einwandfrei (bei Helmut1962 nicht). Füge ich dann rechts davon einen weiteren 3D-Clip hinzu, geht's schon nicht mehr.

    Ingolf, ich arbeite jetzt auch ausschließlich mit dem hochgeladenen PUT-Clip "Importieren_011..." damit wir wenigstens das gleiche Ausgangsmaterial haben. An den 2D-Fotos wird es ja nicht liegen.

    Der Cursor in deinem Screenshot steht bei einem schon einmal exportierten Clip, deshalb die Pixelfehler (Bug Nr.2; Pixelfehler im rechten Auge).

    Gruß, Herbert

     

  •  03-31-2015, 11:50 670782 in reply to 670778

    AW: 3D- Video erstellen, 3 Fragen

    Danny 28:
    Der Cursor in deinem Screenshot steht bei einem schon einmal exportierten Clip, deshalb die Pixelfehler (Bug Nr.2; Pixelfehler im rechten Auge).
    Ja, ja, das habe ich bewusst so gemacht um den Pixelfehler darzustellen.
  •  03-31-2015, 13:19 670790 in reply to 670782

    AW: 3D- Video erstellen, 3 Fragen

    Ich habe jetzt herausbekommen, dass nur manche 2D-Fotos nicht mit den 3D-Clips harmonieren (und zwar die älteren, die mal von Dias abfotografiert wurden). Die neueren 2D-Fotos (die also schon von Anfang an digital waren) funktionieren. Das kann ich mir im Moment aber noch nicht erklären. Vielleicht können die Fotospezialisten (Fritz) dazu schon was sagen?

    Jetzt habe ich natürlich auch mit den neueren Bildern versucht, ein Image zu erstellen. Und siehe da: es geht auch. Das muss ich jetzt erst mal verdauen!

    Ingolf, lässt sich von deinem erfolgreichen Projekt mit dem 2D-Foto zwischen den 3D-Clips auch ein Image erstellen oder bleibt das bei 50% stehen?

    Gruß, Herbert

  •  03-31-2015, 14:38 670793 in reply to 670790

    AW: 3D- Video erstellen, 3 Fragen

    Das Image teste ich morgen
  •  03-31-2015, 17:05 670805 in reply to 670793

    AW: 3D- Video erstellen, 3 Fragen

    Nein, bei mir sind es keine alten Fotos! Alle von digitalen Fotoapparaten, und ja auch bei mir scheitert es immer nur an manchen (aber alle von der gleichen Kamera) ich konnte daher auch ein Image erstellen als ich die beiden an denen St18 hängen geblieben ist, gelöscht habe. Bei meinem neuesten Versuch (Projekt mit 53 Fotos ist das aber eine Wahnsinn, jedes 3 -5 müsste ich löschen, habe es derzeit aufgegeben!
  •  03-31-2015, 18:04 670810 in reply to 670805

    AW: 3D- Video erstellen, 3 Fragen

    Pinnacle - Die Prinzessin auf der Erbse. Hans-Christian Andersen hätte bestimmt seine Freude an unserem Schnittprogramm.
  •  03-31-2015, 18:10 670811 in reply to 670810

    AW: 3D- Video erstellen, 3 Fragen

    Helmut, hasst Du mal versucht, die Betroffenen Fotos durch ein Fotobearbeitungsprogramme gejagt und sie dann neu abgespeichert? Vielleicht funktionieren die Fotos dann. Einen Test wäre es wert. Ggf. auch mal in ein anderes von Pin unterstütztes Format wechseln.
  •  03-31-2015, 19:09 670821 in reply to 670811

    AW: 3D- Video erstellen, 3 Fragen

    Ja, habe sogar alle 53 2D Fotos extern mit dem StereoPhoto Maker zu jps und mpo-Dateien umgewandelt, trotzdem wollte Studio 18 weder eine Multistream-Datei noch ein Image fertigstellen. Was für mich bedeutet, wenn nicht bald ein Bugfix kommt, zurück zu 18.0.2, da so Studio 18 für mich nicht brauchbar ist !!

    Ich brauche Multistream und habe immer Fotos dabei !

  •  03-31-2015, 19:42 670828 in reply to 670821

    AW: 3D- Video erstellen, 3 Fragen

    Ich habe es auch schon mit Umwandlung versucht - kein Erfolg. Wenn bei Updates doch nur das bliebe, was schon einmal funktioniert hat! Zwei Schritte vor und drei zurück.
  •  03-31-2015, 19:59 670831 in reply to 670828

    AW: 3D- Video erstellen, 3 Fragen

    Herbert, schicke mir bitte mal ein Photo das  zum Abbruch führt per Email.
  •  03-31-2015, 21:00 670836 in reply to 670831

    AW: 3D- Video erstellen, 3 Fragen

    So ich habe mal ein kleines Paket mit 3D Fotos (mpo, erstellt mit StereoPhoto Maker aus 2D Fotos) bei mir bleibt die MTS-Datei-Erstellung bei dem 473 Frame hängen !

    Nimmt man das Bild 012.mpo raus, bleibt die Produktion bei Frame 1583 hängen (Bild 157.mpo)!

    Leg ich das Bild 012.mpo an den Anfang wird darüber gerendert und bleibt dann beim Frame 278 hängen aber eben beim Bild 002.mpo wo zuerst drüber gerendert wurde ? !

    https://app.box.com/s/iqjfy5ukllitsp7qppemi4v0hrl62vm9

  •  04-01-2015, 7:28 670860 in reply to 670836

    AW: 3D- Video erstellen, 3 Fragen

    Na endlich komme ich auch mal in den Genuss des "Hängers", danke Helmut für das Projekt-Paket.

    Die Daten meines Multistream-Export-Versuchs mit unverändertem Projekt:

    • Export hängt bei Frame 1733 von 2050 @01:09.07
    • CPU-Auslastung 13% (4 von 8 virtuellen CPUs genutzt)
    • NGStudio Daten
      • Arbeitsspeicher981.100 kB (fast unverändert)
      • Threads 108 (fast unverändert)
      • E/A-Bytes Lesen unverändert
      • E/A-Bytes Schreiben alle 5-6 Sek. ca. 1MB
      • gem. Ress.Monitor werden ~200KB/s in die Exportdatei geschrieben
        Die Exportdatei wächst entsprechend kontinuierlich

    Der Export lässt sich nicht abbrechen. Studio akzeptiert zwar den Button zum Abbrechen, bleibt dann aber mit der Anzeige "Export wird abgebrochen" aktiv. Beenden nur über TaskManager möglich.

    Interessant ist, dass der Export bei mir an einer anderen Stelle hängenbleibt. Mal schauen, ob das reproduzierbar ist.

    Helmut, ich mach jetzt noch den einen oder anderen Versuch. Darf ich ggfl. das Projektpaket bzw. den Link an Pinnacle weitergeben?

    Hier noch die MediaInfo Daten des partiellen Exports. Interessant ist die Dauer, wenn ich die Datei mit dem WMP anspiele, kommt auch so eine verrückte Zeit raus bzw. die Zeitleiste lässt so verrückte Zeiten anwählen.

    Allgemein

    ID : 1 (0x1)
    Vollständiger Name : E:\Test_PS18\Export\635634753734712296.mts
    Format : BDAV
    Format/Info : Blu-ray Video
    Dateigröße : 404 MiB
    Dauer : 4h 7min
    Modus der Gesamtbitrate : variabel
    Gesamte Bitrate : 228 Kbps
    maximale Gesamtbitrate : 28,8 Mbps

    Video #1

    ID : 4113 (0x1011)
    Menü-ID : 1 (0x1)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : High@L4.1
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 2 frames
    Codec-ID : 27
    Dauer : 4h 7min
    Bitraten-Modus : variabel
    maximale Bitrate : 13,1 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 25,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : Interlaced
    Scanreihenfolge : oberes Feld zuerst

    Video #2

    ID : 4114 (0x1012)
    Menü-ID : 1 (0x1)
    Format : AVC
    Format/Info : Advanced Video Codec
    Format-Profil : Stereo High@L4.1
    MultiView_Count : 2
    Format-Einstellungen für CABAC : Ja
    Format-Einstellungen für ReFrames : 2 frames
    Codec-ID : 32
    Dauer : 4h 7min
    Bitraten-Modus : variabel
    maximale Bitrate : 10,9 Mbps
    Breite : 1 920 Pixel
    Höhe : 1 080 Pixel
    Bildseitenverhältnis : 16:9
    Bildwiederholungsrate : 25,000 FPS
    ColorSpace : YUV
    ChromaSubsampling : 4:2:0
    BitDepth/String : 8 bits
    Scantyp : Interlaced
    Scanreihenfolge : unteres Feld zuerst

    Audio

    ID : 4352 (0x1100)
    Menü-ID : 1 (0x1)
    Format : AC-3
    Format/Info : Audio Coding 3
    Format_Settings_ModeExtension : CM (complete main)
    Format-Einstellungen für Endianess : Big
    Codec-ID : 129
    Dauer : 4h 7min
    Bitraten-Modus : konstant
    Bitrate : 384 Kbps
    Kanäle : 6 Kanäle
    Kanal-Positionen : Front: L C R, Side: L R, LFE
    Samplingrate : 48,0 KHz
    BitDepth/String : 16 bits
    Stream-Größe : 679 MiB

  •  04-01-2015, 7:39 670861 in reply to 670836

    AW: 3D- Video erstellen, 3 Fragen

    Danke für die Bereitstellung des Projektes, Helmut!

    Ich kann Ingolfs Erfahrungen bestätigen: 

    Ich habe es bei 0% Hintergrundrendern auf die Timeline, ein Rendern zu MTS in 2D läuft problemlos, wenn ich MTS, HD 1080i, Multistream nehme so bleibt das Rendern beim Frame 1733 stehen. Welche Einstellungen hast Du genommen?


  •  04-01-2015, 7:47 670864 in reply to 670861

    AW: 3D- Video erstellen, 3 Fragen

    Zweiter Versuch ist wieder bei 1733 hängen geblieben. Vorher hatte ich die Renderdateien gelöscht und das HGR-Rendern komplett ablaufen lassen. Optimierungs-Schwellwert war auf 100% eingestellt.

    Da es bei Peter zum gleichen Ergebnis kam, brauche ich ja keine weiteren Versuche mehr zu unternehmen.

    Nachtrag: Ich konnte es nicht unterrlassen, noch einen Versuch durchzuführen:

    Bei den Exporteinstellungen "Vor dem Export vollständig rendern" ausgewählt. Jetzt ist er bei Frame 269 hängen geblieben.

  •  04-01-2015, 10:14 670874 in reply to 670864

    AW: 3D- Video erstellen, 3 Fragen

    Ich konnte es immer noch nicht lassen Wink

    Jetzt habe ich PS18 (18.1.0.602 64-bit) auf mein Notebook installiert und den Test nochmals in der Standard-Variante durchgeführt.

    Ergebnis: Stopp bei Frame 1733

  •  04-01-2015, 14:06 670901 in reply to 670874

    AW: 3D- Video erstellen, 3 Fragen

    Attachment: Einstellungen MTS.JPG

    Meine Einstellungen sind ebenfalls MTS mit 1080i und 26 Mbit und ja der Link bzw. die Datei kann gerne auch Pinnacle testen. Mich wundert zwar, dass es bei 18.1 auch zu Hänger kommt, hatte ich früher nie, zugegeben, mit 18.1 habe ich die 2D Fotos nicht mit SPM zum M3D Fotos umgewandelt sondern den Effekt 3D Tiefeneinstellung verwendet.

     


  •  04-01-2015, 19:56 670951 in reply to 670901

    AW: 3D- Video erstellen, 3 Fragen

    Ich habe die Einstellungen nun auch bei MTS auf Standard 1080i gestellt, dann nimmt Studio nur 24 Mbit statt meine benutzerdefinierten 26 Mbit und siehe da jetzt bleibt auch beim mir der Export beim Frame 1733 hängen, der Bug ist also auch abhängig von der Bitrate. (vermutlich je höher die Bitrate umso öfter oder früher ein Hänger)

    Edit: Bitrate 40 Mbit, Hänger bei Frame 170 !!

Page 3 of 4 (88 items)   < Previous 1 2 3 4 Next >
View as RSS news feed in XML
Copyright © 2012 Corel, Inc.. Terms of Use | Privacy Policy